当前位置:首页>文章>PHP

Linux下强制卸载php方法

卸载php的命令,使用命令yum remove php是不够的,因为yum并不会帮你把php完全卸载掉,如果你使用php -v可以发现php的版本号仍然存在。

正确的卸载php的方法是:删除php的rpm安装包(其实yum安装在根本上还是使用的rpm包,只是yum安装能解决rpm安装时发生的包依赖问题)。

命令如下:

#rpm -qa|grep php列出所有的php相关的rpm包

#rpm -e xxx xxx指的是上一个命令列出的rpm包的包名,复制即可。这一步卸载安装的php的rpm包,注意因为可能存在依赖关系会发生报错,所以可能需要调整下要写在的rpm包的顺序。

如果调整了rpm包的顺序,还是无法删除剩余的包,可以通过强制删除来解决:

#rpm -e xxx --nodeps其中xxx指的还是rpm包名

强制删除后,就可以重新安装php了:

# yum -y install php可以换个yum源,安装其他版本的php,因为centOS6.6的源只给出了php5.3的源。


相关阅读: